summaryrefslogtreecommitdiff
path: root/plugins/kolab_auth/package.xml
blob: 00bc969b4588c67533552f0e7e7388e060537912 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
<?xml version="1.0" encoding="UTF-8"?>
<package xmlns="http://pear.php.net/dtd/package-2.0" xmlns:tasks="http://pear.php.net/dtd/tasks-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" packagerversion="1.9.0" version="2.0" xsi:schemaLocation="http://pear.php.net/dtd/tasks-1.0
    http://pear.php.net/dtd/tasks-1.0.xsd
    http://pear.php.net/dtd/package-2.0
    http://pear.php.net/dtd/package-2.0.xsd">
	<name>kolab_auth</name>
    <uri>http://git.kolab.org/roundcubemail-plugins-kolab/</uri>
	<summary>Kolab Authentication</summary>
	<description>
        Authenticates on LDAP server, finds canonized authentication ID for IMAP
        and for new users creates identity based on LDAP information.
        Supports impersonate feature (login as another user). To use this feature
        imap_auth_type/smtp_auth_type must be set to DIGEST-MD5 or PLAIN.
	</description>
	<lead>
		<name>Aleksander Machniak</name>
		<user>machniak</user>
		<email>machniak@kolabsys.com</email>
		<active>yes</active>
	</lead>
	<date>2013-06-25</date>
	<version>
		<release>0.7</release>
		<api>0.2</api>
	</version>
	<stability>
		<release>stable</release>
		<api>stable</api>
	</stability>
	<license uri="http://www.gnu.org/licenses/agpl.html">GNU AGPLv3</license>
	<notes>-</notes>
	<contents>
		<dir baseinstalldir="/" name="/">
			<file name="kolab_auth.php" role="php">
				<tasks:replace from="@name@" to="name" type="package-info"/>
				<tasks:replace from="@package_version@" to="version" type="package-info"/>
			</file>
			<file name="kolab_auth_ldap.php" role="php">
				<tasks:replace from="@name@" to="name" type="package-info"/>
				<tasks:replace from="@package_version@" to="version" type="package-info"/>
			</file>
			<file name="config.inc.php.dist" role="data"></file>
			<file name="LICENSE" role="data"></file>

			<file name="localization/de_CH.inc" role="data"></file>
			<file name="localization/de_DE.inc" role="data"></file>
			<file name="localization/en_US.inc" role="data"></file>
			<file name="localization/pl_PL.inc" role="data"></file>
		</dir>
		<!-- / -->
	</contents>
	<dependencies>
		<required>
			<php>
				<min>5.2.1</min>
			</php>
			<pearinstaller>
				<min>1.7.0</min>
			</pearinstaller>
		</required>
	</dependencies>
	<phprelease/>
</package>