summaryrefslogtreecommitdiff
path: root/ext/pdo_oci
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2008-07-25 13:46:24 (GMT)
committerJani Taskinen <jani@php.net>2008-07-25 13:46:24 (GMT)
commit281352fe023e30fea30af60adda3b69acd70bd46 (patch)
tree51462b055267d044860284ad925674b5f96d6069 /ext/pdo_oci
parent1f7e547662939345f74ad8731b923b3927d0b6f2 (diff)
downloadphp-281352fe023e30fea30af60adda3b69acd70bd46.tar.gz
MFH: Fix PDO configure dependancy: If --disable-pdo is used, disable all
MFH: enabled-by-default drivers. Also error out if you try to configure MFH: a driver as static but pdo is disabled.
Diffstat (limited to 'ext/pdo_oci')
-rwxr-xr-xext/pdo_oci/config.m411
1 files changed, 7 insertions, 4 deletions
diff --git a/ext/pdo_oci/config.m4 b/ext/pdo_oci/config.m4
index ec6747e..3ebb154 100755
--- a/ext/pdo_oci/config.m4
+++ b/ext/pdo_oci/config.m4
@@ -1,6 +1,6 @@
dnl $Id$
-
-if test "$PHP_PDO" != "no"; then
+dnl config.m4 for extension pdo_oci
+dnl vim:et:sw=2:ts=2:
AC_DEFUN([AC_PDO_OCI_VERSION],[
AC_MSG_CHECKING([Oracle version])
@@ -61,6 +61,11 @@ PHP_ARG_WITH(pdo-oci, Oracle OCI support for PDO,
--with-pdo-oci=instantclient,/usr,10.2.0.3])
if test "$PHP_PDO_OCI" != "no"; then
+
+ if test "$PHP_PDO" = "no" && test "$ext_shared" = "no"; then
+ AC_MSG_ERROR([PDO is not enabled! Add --enable-pdo to your configure line.])
+ fi
+
AC_MSG_CHECKING([Oracle Install-Dir])
if test "$PHP_PDO_OCI" = "yes" || test -z "$PHP_PDO_OCI"; then
PDO_OCI_DIR=$ORACLE_HOME
@@ -254,5 +259,3 @@ You need to tell me where to find your Oracle Instant Client SDK, or set ORACLE_
AC_DEFINE_UNQUOTED(PHP_PDO_OCI_CLIENT_VERSION, "$PDO_OCI_VERSION", [ ])
fi
-
-fi