summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Wickert <wickert@kolabsys.com>2011-09-17 13:51:26 (GMT)
committerChristoph Wickert <wickert@kolabsys.com>2011-09-17 13:51:26 (GMT)
commit894ec6f5bf3bab26068cd806bd14501129b1dc61 (patch)
tree1af7ee4fc08787607b34da7a4f8ddbe37f11f479
parent7a5433de527d0f039fdf14a3b59dfef8c4e0e7c4 (diff)
downloadserver-894ec6f5bf3bab26068cd806bd14501129b1dc61.tar.gz
imapd: Bring back the workaround for missing user_deny.db (bugzilla.kolabsys.com #72)
-rw-r--r--imapd/imapd.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/imapd/imapd.spec b/imapd/imapd.spec
index 9d5c1f2..14c78d4 100644
--- a/imapd/imapd.spec
+++ b/imapd/imapd.spec
@@ -32,8 +32,7 @@ Class: BASE
Group: Mail
License: BSD
Version: 2.3.17
-Release: 20110909_kolab1
-
+Release: 20110909_kolab2
# package options
%option with_fsl yes
%option with_group no
@@ -76,6 +75,7 @@ Patch4: patches/cyrus-imapd-%{version}/KOLAB_cyrus-imapd-%{version}_Loggin
Patch5: patches/cyrus-imapd-%{version}/KOLAB_cyrus-imapd-%{version}_UID.patch
Patch6: patches/cyrus-imapd-%{version}/KOLAB_cyrus-imapd-%{version}_Folder-names.patch
Patch7: patches/cyrus-imapd-%{version}/KOLAB_cyrus-imapd-%{version}_timsieved_starttls-sendcaps.patch
+Patch8: patches/cyrus-imapd-%{version}/KOLAB_cyrus-imapd-%{version}_workaround-for-missing-user_deny.db.patch
# build information
Prefix: %{l_prefix}
@@ -160,6 +160,10 @@ AutoReqProv: no
%patch -p1 -P 7
%endif
+ # kolab/issue4729 (Kolab 2.3.0 lacks /kolab/var/imapd/user_deny.db)
+ # bugzilla.kolabsys.com #72 (user_deny.db not found)
+%patch -p1 -P 8
+
# add optional DRAC file support
%if "%{with_drac}" == "yes"
%{l_shtool} subst -e 's;@DRACLIBS@;-ldrac;g' contrib/drac_auth.patch
@@ -430,6 +434,9 @@ AutoReqProv: no
%changelog
+* Sat Sep 17 2011 Christoph Wickert <wickert@kolabsys.com> - 2.3.17-20110909_kolab2
+- Bring back the workaround for missing user_deny.db (bugzilla.kolabsys.com #72)
+
* Fri Sep 09 2011 Christoph Wickert <wickert@kolabsys.com> - 2.3.17-20110909_kolab1
- Update to 2.3.17, fixes CVE-2011-3208