summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com>2012-09-08 14:42:18 (GMT)
committerJeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com>2012-09-08 14:42:18 (GMT)
commit1c1c2d4bb8221b35bf159c8bade98793cecb417c (patch)
tree6bc6fea7444a880c08a25efb8ce2e5c0d0fadaef
parent79abaa9f97d932dd85d476f8d29a913e00f35651 (diff)
downloadkolab-docs-1c1c2d4bb8221b35bf159c8bade98793cecb417c.tar.gz
Update Installation Guide Makefile to reflect the community/enterprise division/duplication
Re-enable the APT repository setup section
-rw-r--r--Installation_Guide/Makefile21
-rw-r--r--Installation_Guide/en-US/sect-Repository_Configuration-Installation_with_APT_Packages.xml173
2 files changed, 42 insertions, 152 deletions
diff --git a/Installation_Guide/Makefile b/Installation_Guide/Makefile
index 413fb72..1cbf28d 100644
--- a/Installation_Guide/Makefile
+++ b/Installation_Guide/Makefile
@@ -3,13 +3,22 @@ PACKAGE = "Installation_Guide"
include ../Makefile.common
all: clean clean_ids update-language
- @for audience in enterprise community; do \
+ for audience in enterprise community; do \
sed -r -i -e "s/^condition:.*/condition: $$audience/g" publican.cfg; \
sed -r -i -e "s/^docname:.*/docname: $$(echo $${audience:0:1} | tr '[:lower:]' '[:upper:]')$${audience:1}_$(PACKAGE)/g" publican.cfg; \
- publican build --embedtoc --publish --langs=all --formats=html,html-single,pdf; \
- for lang in $$(ls -d *-*); do \
- publican install_book --site_config=../site.cfg --lang=$$lang; \
- done; \
+ make clean clean_ids; \
+ if [ "$(SKIP_UPDATE_LANG)" == "1" ]; then \
+ publican build --embedtoc --publish --langs=en-US --formats=html,html-single,pdf; \
+ else \
+ publican build --embedtoc --publish --langs=all --formats=html,html-single,pdf; \
+ fi; \
+ if [ "$(SKIP_UPDATE_LANG)" == "1" ]; then \
+ publican install_book --site_config=../site.cfg --lang=en-US; \
+ else \
+ for lang in $$(ls -d *-* | grep -v en-US); do \
+ publican install_book --site_config=../site.cfg --lang=$$lang; \
+ done; \
+ fi; \
done
- @sed -r -i -e 's/^condition:.*/condition: community/g' publican.cfg
+ sed -r -i -e 's/^condition:.*/condition: community/g' publican.cfg
diff --git a/Installation_Guide/en-US/sect-Repository_Configuration-Installation_with_APT_Packages.xml b/Installation_Guide/en-US/sect-Repository_Configuration-Installation_with_APT_Packages.xml
index b91aafb..766b98c 100644
--- a/Installation_Guide/en-US/sect-Repository_Configuration-Installation_with_APT_Packages.xml
+++ b/Installation_Guide/en-US/sect-Repository_Configuration-Installation_with_APT_Packages.xml
@@ -7,11 +7,10 @@
<title>Installation with APT Packages</title>
<important>
<para>
- APT packages for Kolab 3.0 are actively being worked on, but are not yet available.
+ APT packages for Kolab 3.0 on Debian Wheezy are a work in progress.
</para>
</important>
- <!--
<para>
APT packages are provided for the following GNU/Linux distributions, and distribution versions:
</para>
@@ -51,34 +50,16 @@
</row>
</thead>
-<tbody>
- <row>
- <entry>
- Debian
- </entry>
- <entry>
- Lenny (oldstable)
- </entry>
- <entry>
- 5.0
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- February 6th, 2012
- </entry>
-
- </row>
- <row>
+ <tbody>
+ <row condition="community">
<entry>
Debian
</entry>
<entry>
- Squeeze (stable)
+ Wheezy (testing)
</entry>
<entry>
- 6.0
+ 7.0
</entry>
<entry>
i386, amd64
@@ -88,7 +69,7 @@
</entry>
</row>
- <row condition="community">
+ <row condition="enterprise">
<entry>
Debian
</entry>
@@ -124,114 +105,6 @@
</entry>
</row>
- <row condition="enterprise">
- <entry>
- Ubuntu
- </entry>
- <entry>
- Dapper
- </entry>
- <entry>
- 6.06 LTS
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
- <row condition="enterprise">
- <entry>
- Ubuntu
- </entry>
- <entry>
- Hardy
- </entry>
- <entry>
- 8.04 LTS
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
- <row condition="enterprise">
- <entry>
- Ubuntu
- </entry>
- <entry>
- Karmic
- </entry>
- <entry>
- 9.10
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
- <row>
- <entry>
- Ubuntu
- </entry>
- <entry>
- Lucid
- </entry>
- <entry>
- 10.04 LTS
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
- <row>
- <entry>
- Ubuntu
- </entry>
- <entry>
- Maverick
- </entry>
- <entry>
- 10.10
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
- <row condition="community">
- <entry>
- Ubuntu
- </entry>
- <entry>
- Natty
- </entry>
- <entry>
- -
- </entry>
- <entry>
- i386, amd64
- </entry>
- <entry>
- T.B.D.
- </entry>
-
- </row>
</tbody>
@@ -248,23 +121,26 @@
Install the <application>apt-transport-https</application> package:
</para>
<para>
- <screen># <userinput>aptitude install apt-transport-https</userinput></screen>
+
+<screen># <userinput>aptitude install apt-transport-https</userinput></screen>
+
</para>
+
</step>
<step>
<para>
- For Kolab &PRODUCT_VERSION; software packages for Debian Squeeze, add the following two lines to <filename>/etc/apt/sources.list.d/kolab-&PRODUCT_VERSION;.list</filename>:
+ For Kolab &PRODUCT_VERSION; software packages for Debian Wheezy, add the following two lines to <filename>/etc/apt/sources.list.d/kolab-&PRODUCT_VERSION;.list</filename>:
</para>
<para condition="community">
-<screen>deb http://mirror.kolabsys.com/pub/debian/kolab-&PRODUCT_VERSION;/ squeeze release updates
-deb-src http://mirror.kolabsys.com/pub/debian/kolab-&PRODUCT_VERSION;/ squeeze release updates</screen>
+<screen>deb http://mirror.kolabsys.com/pub/debian/kolab-&PRODUCT_VERSION;/ wheezy release updates
+deb-src http://mirror.kolabsys.com/pub/debian/kolab-&PRODUCT_VERSION;/ wheezy release updates</screen>
</para>
<para condition="enterprise">
-<screen>deb https://mirror.kolabsys.com/debian/kolab-&PRODUCT_VERSION;/ squeeze release updates
-deb-src https://mirror.kolabsys.com/debian/kolab-&PRODUCT_VERSION;/ squeeze release updates</screen>
+<screen>deb https://mirror.kolabsys.com/debian/kolab-&PRODUCT_VERSION;/ wheezy release updates
+deb-src https://mirror.kolabsys.com/debian/kolab-&PRODUCT_VERSION;/ wheezy release updates</screen>
</para>
<note>
@@ -275,7 +151,7 @@ deb-src https://mirror.kolabsys.com/debian/kolab-&PRODUCT_VERSION;/ squeeze rele
</note>
<para>
- For other versions of the Debian distribution, please replace <code>squeeze</code> with the corresponding distribution codename.
+ For other versions of the Debian distribution, please replace <code>wheezy</code> with the corresponding distribution codename.
</para>
</step>
@@ -298,13 +174,14 @@ Pin-Priority: 501</screen>
</para>
<para>
-<screen>$ <userinput>gpg &min;&min;search squeeze-packages@kolabsys.com</userinput></screen>
+<screen>$ <userinput>gpg &minus;&minus;search wheezy-packages@kolabsys.com</userinput></screen>
</para>
+ <!--
<para>
- For Debian Lenny, please replace <code>squeeze</code> with the corresponding distribution codename.
+ For Debian Lenny, please replace <code>wheezy</code> with the corresponding distribution codename.
</para>
-
+ // -->
</step>
<step condition="enterprise">
<para>
@@ -339,8 +216,11 @@ Pin-Priority: 501</screen>
Verify the packages from the Kolab mirror have priority over the packages from the stock Debian repositories:
</para>
<para>
- <screen># <userinput>apt-cache policy cyrus-imapd</userinput></screen>
+
+<screen># <userinput>apt-cache policy cyrus-imapd</userinput></screen>
+
</para>
+
</step>
<step>
<para>
@@ -454,7 +334,7 @@ E: Broken packages</screen>
</para>
<para>
-<screen># <userinput>aptitude install kolabd</userinput></screen>
+<screen># <userinput>aptitude install kolab</userinput></screen>
</para>
@@ -462,7 +342,8 @@ E: Broken packages</screen>
</section>
- // -->
+
+
</section>